Microsoft Office Tutorials and References
In Depth Information
Abbildung 5.20: Mit Wahrheitswerten können Sie rechnen.
Der Fehlerwert #DIV/0! resultiert daher, dass mathematisch eine Division durch Null
(bzw. FALSCH) einfach nicht zulässig ist. In den anderen Beispielen werden die Wahr-
heitswerte in die Zahlen 1 und 0 umgewandelt. Exakt dieses Prinzip wird beispiels-
weise in der Funktion SUMMEWENN gebraucht.
=SUMMEWENN(A1:A5;"x";B1:B5)
summiert alle Werte aus B1:B5, wenn die zugehörige Zelle in A1:A5 ein „x” enthält.
Dabei wird jede Zelle aus dem Bereich A1:A5 nacheinander auf die Übereinstimmung
mit „x“ geprüft. Ist das Ergebnis WAHR, wird der Wert aus Spalte B summiert, ist das
Ergebnis FALSCH, wird eben nicht summiert. Mathematisch stellen Sie sich einfach
vor, dass der Wert aus Spalte B mit dem Wahrheitswert WAHR oder FALSCH multi-
pliziert wird. Bei FALSCH wird also mit Null multipliziert (Zahl*FALSCH = 0), bei
WAHR mit 1 (Zahl*WAHR = Zahl). Und die Summe aller Einzelergebnisse führt dann
zum Gesamtergebnis.
Eines der am häufigsten vorkommenden Probleme ist nun aber, dass eine Spalte nur
dann summiert werden soll, wenn davor zwei Spalten bestimmte Werte enthalten.
Dafür haben uns die Microsoft-Entwickler lange eine passende Funktion vorent-
halten. Erst seit der Version 2007 gibt es die Funktion SUMMEWENNS, die dieses
Versäumnis beseitigt. Bis zur Excel-Version 2003 hingegen kommen Sie nicht um
einen Workaround herum. In folgendem Beispiel soll Spalte C nur summiert werden,
wenn der Wert in Spalte A „x“ und der Wert in Spalte B „y“ ist (Abbildung 5.21).
Search JabSto ::




Custom Search