Microsoft Office Tutorials and References
In Depth Information
In Gänze:
=SUMME({WAHR;WAHR;FALSCH;WAHR;FALSCH}*{WAHR;FALSCH;FALSCH;WAHR;WAHR}*{2;3;4;5;6})
Wir erhalten also drei Arrays. Jetzt wird jedes Element des einen Arrays mit dem ent-
sprechenden Element der anderen Arrays multipliziert. Werten wir nur die Multipli-
kation der ersten beiden Wahrheitsarrays aus, erhalten wir:
=SUMME({1;0;0;1;0}*{2;3;4;5;6})
Zu guter Letzt werden die beiden übrig gebliebenen Arrays vereint, sodass das Ergebnis
=SUMME({2;0;0;5;0}) = 7
übrig bleibt. Hier bleibt abschließend festzuhalten, dass ausschließlich die Multi-
plikation von zwei (oder mehr) WAHR zum Ergebnis 1 führt, alle anderen ergeben null.
Abbildung 5.23: Multiplikation von Wahrheitswerten
Mithilfe der Wahrheitswerte kann man auch häufig auf die WENN-Funktion verzichten.
=WENN(A1=5;16;10)
ist identisch mit
=10+6*(A1=5)
Wenn in A1 eine 5 steht, ergibt der Wahrheitswert (A1=5) WAHR. Und 6*WAHR = 6 .
Steht in A1 hingegen keine 5, ergibt (A1=5) FALSCH – und 6*FALSCH = 0 . Also wird
zur Zahl 10 entweder 6 oder 0 addiert, und damit hat man beide Bedingungen der
WENN-Funktion abgedeckt. Ein weiteres Beispiel:
Search JabSto ::




Custom Search