Microsoft Office Tutorials and References
In Depth Information
SPALTE(A1) wird zu SPALTE(B1), SPALTE(C1) etc. – also wiederum 1, 2, 3. Das war
aber erst das Warm-up. Jetzt ringen wir diesen Funktionen ihre gesamte Genialität
ab: Sie können auch in der Form
ZEILE(von:bis)
SPALTE(von:bis)
angegeben werden und in dieser Weise ein ganzes Array von Zahlen aufnehmen und
zurückgeben.
Von:bis versteht sich hierbei als Platzhalter für eine Zahlenreihe von:bis . Diese Zahlen-
reihe ist zunächst begrenzt auf die verfügbare Zeilen- bzw. Spaltenzahl eines Tabellen-
blattes. Seit XL2007 kann es also heißen:
=ZEILE(1:1048576) oder auch =ZEILE(A:A)
=SPALTE(A:XFD) oder auch =SPALTE(1:1)
Bis XL2003 sind es nur 65536 Zeilen und 256 (IV) Spalten.
Da das Verständnis hierfür elementar wichtig ist, zunächst ein paar einfache Beispiele.
Nehmen wir an, Sie möchten die Zahlen von 1 bis 5 summieren. Dazu bietet sich an:
=SUMME(1;2;3;4;5) = 15
Im nächsten Schritt möchten Sie die Zahlen von 1 bis 100 summieren. In XL2007
sind nun 255 Einzelparameter möglich, aber
=SUMME(1;2;3;4;...;100)
wäre natürlich eine nervende Tipparbeit. Aber auch hier ist die Lösung immer noch
einfach. Sie schreiben untereinander in A1:A100 die Zahlen 1 bis 100, und summieren
Sie dann mit =SUMME(A1:A100) – ergibt korrekt 5.050.
Wenn Sie bis hierhin aufgepasst haben, wissen Sie, dass Sie eine Zahlenfolge von 1
bis 100 schnell mit der Funktion =ZEILE() erzeugen können: in A1 eintragen und ein-
fach bis A100 herunterkopieren (Abbildung 5.25):
Search JabSto ::




Custom Search