Microsoft Office Tutorials and References
In Depth Information
Entwicklungskosten lösten sich gleichzeitig in Weltraumschrott auf. Das alles wäre
nicht passiert, hätte man die Integer-Variable für die neue Rakete durch einen passen-
den Variablentyp – z.B. Double – ausgetauscht. Ein wahrlich teueres Versäumnis …
(siehe u.a.: http://www-aix.gsi.de/~giese/swr/ariane5.html )
Für den reinen Excel-Anwender reichen allerdings wenige Kenntnisse über Daten-
typen aus. Es gibt lediglich sechs relevante Datentypen:
Zahl
Text
Wahrheitswert
Matrix
Bezug
Fehlerwert
Gehen wir sie einzeln durch:
Zahl
Eine Zahl wird innerhalb einer Excel-Zelle standardmäßig rechtsbündig dargestellt.
Ist es für einen Programmierer interessant, zwischen Ganz- und Dezimalzahlen
sowie Größenordnungen zu unterschieden, so kann Ihnen das als Excel-Anwender
ganz egal sein: Es wird immer automatisch der richtige „Zahl-Datentyp“ zugewiesen.
Einen Raketenabsturz können Sie keinesfalls herbeiführen.
Zahlen werden stets „nackt“ eingegeben, also niemals in Anführungszeichen oder
Ähnliches gekleidet (nicht "1", sondern nur 1). Je nach Ländereinstellung sind Punkt
oder Komma das Dezimaltrennzeichen (deutsch: Komma, englisch: Punkt).
Text
Ein Text wird innerhalb einer Excel-Zelle standardmäßig linksbündig dargestellt. Der
Text kann dabei beliebig lang sein, allerdings ist dessen Anzeige innerhalb einer Zelle
begrenzt. Text, der direkt einem Funktionsparameter zugewiesen wird, muss in
"Anführungszeichen" gesetzt werden:
=WENN(A1=1;"Eine 1";"Keine 1")
Search JabSto ::




Custom Search