Microsoft Office Tutorials and References
In Depth Information
N3: =RUNDEN(1/(1+IKV($J$2:$J$6;M3));6)
IKV hat jetzt bei neun Versuchen alle vier Nullstellen gefunden. Dadurch sind man-
che Ergebnisse natürlich redundant, aber das stört ja nicht. Mit der Formel
O3:=(ZÄHLENWENN(N$3:N3;N3)=1)*(MAX(O$2:O2)+1) (kopieren bis O3:O11)
können Sie markieren, ob eine Nullstelle redundant ist (0) oder erstmalig gefunden
wurde (1, 2, 3 ,4).
Es empfiehlt sich, das Ergebnis von IKV nach einigen Stellen zu runden, da sonst
Rundungsdifferenzen auftauchen können. Dann würden zwei Nullstellen, die sich
erst in der zehnten Nachkommastelle unterscheiden, als zwei unterschiedliche Null-
stellen interpretiert, obwohl es ein und dieselbe ist.
Um die Nullstellen ohne Duplikate aufzulisten, schreiben Sie in P3:
P3:=INDEX(N:N;VERGLEICH(Zeile()-2;O:O;0))
kopieren bis P6 nach unten und fügen diesen Bereich als x-Werte einer neuen Daten-
reihe in das Diagramm ein (A10:A13). Als y-Werte definieren Sie B10:B13 {0.0.0.0}
(denn bei Nullstellen muss y ja immer null sein).
Wenn Sie die Datenpunkte der Nullstellen formatieren, wird das Ergebnis etwa aus-
sehen wie in Abbildung 8.19. Die Formel in B10 erbringt den Nachweis, dass der
Funktionswert an dieser x-Position 0 ergibt.
Abbildung 8.19: Polynomnullstellen im Diagramm anzeigen
Search JabSto ::




Custom Search