Microsoft Office Tutorials and References
In Depth Information
In Spalte G wird das Intervall der Startwerte eingetragen. Spalte H enthält die Ziel-
werte, die Excel gefunden hat, und Spalte I den Absolutwert des jeweiligen y-Wer-
tes. Natürlich kommen in der Liste dieselben Nullstellen mehrfach vor. Wir berück-
sichtigen nur die Treffer, bei denen der Y-Wert in Bezug auf die entsprechende
Nullstelle am geringsten ist. Dies sind Treffer in Zeile 2, 7, 9 und 15. Die übrigen wer-
den verworfen. Z.B. wurde in den Zeilen 15 bis 17 dieselbe Nullstelle gefunden. Zeile
15 ist mit einem y-Wert von 0,000021 aber am nächsten dran, deshalb werden die
beiden anderen Treffer ignoriert.
Natürlich könnte das Makro noch die verworfenen Treffer löschen, aber wir wollen
an dieser Stelle dem Kapitel 13 nicht zu weit vorausgreifen.
Die Zielwertsuche ist so flexibel, dass sie auch für völlig anders gelagerte Problemstel-
lungen Lösungen findet, zum Beispiel bei trigonometrischen Berechnungen. Gleichwohl
heißt sie nicht Nostradamus. Man muss ihr immer die Chance geben, sich einer Lösung
anzunähern. Wenn sie nur die Möglichkeit hat, wahllos zu suchen, wird sie versagen.
Zum Beispiel stehen in der Abbildung 8.32 in Spalte D Zahlen von 1 bis 10, denen ohne
jegliche Bildungsregel Zahlen in Spalte E zugeordnet sind. In A1 wird eine Zahl einge-
tragen und in A2 über SVERWEIS der entsprechende Eintrag von Spalte E gezogen.
Abbildung 8.32: Vergebliche Zielwertsuche
A2: =SVERWEIS(A1;D1:E10;2;0)
Mit der Zielwertsuche
Zielzelle: A2
Zielwert: 10
Veränderbare Zelle: A1
Search JabSto ::




Custom Search