Microsoft Office Tutorials and References
In Depth Information
In B1 wird die Nutzungsdauer aller Anlagen der Gruppe angegeben. Für die geome-
trisch-degressive AfA steht in B2:
B2:= MIN(3/B1;0,3)
In Spalte D werden in beliebigen Zeilen Anschaffungskosten eingetragen. Die kumu-
lierte AfA nach linearer Methodik ergibt sich dann aus:
E4: =SUMME(INDIREKT("D"&MAX(1;ZEILE()-n)):D3)/n
Für jede AfA-Ermittlung sind die letzten n Anschaffungen aus Spalte D maßgeblich.
Die Funktion INDIREKT ermittelt deshalb einen Bereich aus den vorherigen n Zeilen.
Aus Sicht der Zelle E8 also den Bereich D3:D7. MAX(1;ZEILE()-n) ist notwendig, da
der Bereich in Spalte D mindestens in der ersten Zeile beginnen muss. Denn die letz-
ten n Zellen aus Sicht von E4 wären E-2:E3, und da spielt Excel einfach nicht mit.
Deshalb wird der Bereich in diesem Fall auf E1:E3 gekürzt.
E4 wird nach unten kopiert. Für die lineare AfA mussten die letzten n Anschaffungen
bloß addiert und durch n geteilt werden. Die gleiche Berechnung bei geometrisch-
degressiver AfA – mit Methodenwechsel! – ist da schon wesentlich kniffliger:
F4:{=SUMME(VDB(INDIREKT("D"&MAX(ZEILE($A$3);ZEILE()-n)):D3;0;n;ZEILE()-
ZEILE(INDIREKT("D"&MAX(ZEILE($A$3);ZEILE()-n)):D3)-1;ZEILE()-
ZEILE(INDIREKT("D"&MAX(ZEILE($A$3);ZEILE()-n)):D3);n*$B$2))}
Diese Array-Formel wird nach unten kopiert. Um die Formel in Spalte F zu kapieren,
dröseln wir sie aus Sicht von Zelle F8 schrittweise auf.
Ähnlich wie im linearen Fall werden zunächst mit INDIREKT und MAX die maßgeb-
lichen Vorperioden ermittelt. Aus Sicht von F8 ist es der Bereich D3:D7, also bleibt:
F8:=SUMME(VDB(D3:D7;0;n;ZEILE()-ZEILE(D3:D7)-1;ZEILE()-ZEILE(D3:D7);n*$B$2))
Der Formelteil ZEILE()-ZEILE(D3:D7) erzeugt hier zwei absteigende Arrays, die alle
Vorperioden enthalten. Wertet man sie mit der Taste (F9) aus, bleibt:
F8:{=SUMME(VDB(D3:D7;0;n;{4;3;2;1;0};{5;4;3;2;1};n*$B$2))}
Nachdem nun etwas Licht in den Formelnebel gebracht wurde, ist zu erkennen, dass
die Funktion VDB in dieser Array-Formel fünfmal angewendet wird. Würde man sie
in diese fünf Einzelteile zerlegen und diese addieren, käme das Gleiche heraus:
Search JabSto ::




Custom Search