Microsoft Office Tutorials and References
In Depth Information
13.7.1
Mehrfachoperationen
Die Table -Methode gibt nicht sonderlich viel her. Sie können damit lediglich mit der
Anweisung
Range("MOP_Bereich").Table _
RowInput:=Range("Zeilenkriterium"), _
ColumnInput:=Range("Spaltenkriterium")
die Mehrfachoperation erzeugen, die Sie auch manuell erzeugen könnten. Der Befehl
funktioniert natürlich nur, wenn MOP_Bereich so konfiguriert ist, wie die MOP das
verlangt. Daran sind ja drei Bedingungen geknüpft:
Erste Spalte muss die Varianten des Spaltenkriteriums beinhalten.
1.
Erste Zeile muss die Varianten des Zeilenkriteriums beinhalten.
2.
Schnittpunkt links oben muss die Zielgröße enthalten.
3.
Also wenn Sie schon die MOP per VBA ausführen, können Sie bei der Gelegenheit
auch die Konfiguration der Tabelle mit verhackstücken. Ein Beispiel:
In B1:B5 stehen die Input-Größen einer Investitionsrechnung. Der daraus resultie-
rende Zeitstrahl wird in A8:B23 abgebildet. Spalte A enthält den Zeitpunkt t, und der
Zahlungsstrom ergibt sich aus:
B8:=B1
B9:=B2
B10:= WENN(A10>$B$3;0;B9*(1+$B$4))
B10 wird nach unten kopiert. Ziel ist es, aus dieser Zahlungsreihe den Nettobarwert
zu ermitteln:
B6: =NBW(B5;B9:B23)+B8
Als Nächstes soll eine Mehrfachoperation durchgeführt werden, die den Nettobar-
wert für verschiedene Laufzeiten und Zinssätze durchrechnet.
Dem Bereich D3:J16 wurde der Name MOP_Bereich vergeben. Abbildung 13.32 zeigt
bereits das fertige Ergebnis der MOP. Wie sie manuell erzeugt wird, haben wir bereits
in Kapitel 10 erläutert.
Search JabSto ::




Custom Search