Microsoft Office Tutorials and References
In Depth Information
die Schnelle eine Berechnung durchführen möchten. Als Beispiel sei die Funktion
NETTOARBEITSTAGE genannt, deren Nachbau mit den Standardfunktionen zwar
möglich, aber sehr kompliziert ist.
=NETTOARBEITSTAGE(A1;A2;C1:C20)
kann ersetzt werden durch die Array-Formel (mit (Strg) + (ª) + (¢) abschließen):
{=SUMME((WOCHENTAG(ZEILE(INDIREKT(A1&":"&A2));2)<6)*1)-
SUMME(WENN((C1:C20>=A1)*(C1:C20<=A2)*(WOCHENTAG(C1:C20;2)<6);1;0))}
A1 enthält das Startdatum, A2 das Enddatum und C1:C20 auszuschließende Feiertage.
Zu guter Letzt gibt es aber auch Analysefunktionen, die dermaßen leistungsstark
sind, dass sie mit Bordmitteln kaum oder gar nicht nachzustellen sind. Beispielhaft
sei hier die Funktion GGT genannt, die den größten gemeinsamen Teiler aus bis zu
255 Zahlen ermittelt. Diese mit Standardfunktionen nachzubauen ist nur unter Ein-
schränkungen möglich und ziemlich kompliziert:
{=WENN(UND(REST(B1:E1;A1)=0);A1;MAX(WENN(MMULT(REST(A1:E1;ZEILE(INDIREKT("1:"&
GANZZAHL($A$1/2))));{1;1;1;1;1})=0;ZEILE(INDIREKT("1:"&GANZZAHL($A$1/2))))))}
Dagegen macht
=GGT(A1:E1)
doch ’nen richtig schlanken Fuß und ist außerdem leistungsstärker. Aber: Diese Ana-
lysefunktionen hatten bis XL2003 trotzdem ein Rad ab!
Gibt man eine „normale“ Funktion ohne jeglichen Bezug in eine Zelle ein, erhält man
beispielsweise bei =SUMME: :#NAME?
Bei =NETTOARBEITSTAGE oder =QUOTIENT oder =WURZELPI erhielt man z.B. tatsächlich
„Ergebnisse“: –1.335.885.768 und –643.039.222 und –1.707.081.719.
Unschön war außerdem, dass die Add-Ins überhaupt keine Kontrolle über eine valide
Eingabesyntax hatten. Wenn man bei Standardfunktionen zu viele oder zu wenige
Argumente eingibt, erscheint eine Fehlermeldung in Abbildung 2.2.
Abbildung 2.2: Fehlermeldung bei zu vielen (oder zu wenigen) Argumenten
Search JabSto ::




Custom Search