Microsoft Office Tutorials and References
In Depth Information
SUMMENPRODUKT()
SUMPRODUCT()
Syntax:
SUMMENPRODUKT( Array1 ; Array2; Array3; …)
Beispiel:
=SUMMENPRODUKT({4.5.6};{1.2.3})
ergibt 32 für (4*1+5*2+6*3)
Die Funktion SUMMENPRODUKT() bewirkt, dass die einzelnen Elemente der als Ar-
gumente angegebenen Matrizen der Reihe nach miteinander multipliziert und an-
schließend die Multiplikationsergebnisse summiert werden. Die Matrizen müssen
von der Zeilenanzahl und der Spaltenanzahl her gleich sein. Es handelt sich also
nicht um ein Summenprodukt, sondern um eine Produktensumme. Seit Excel
2007 sind 2 bis 255 Matrizen als Argumente erlaubt, in den älteren Versionen nur
2 bis 30. Nichtnumerische Elemente in einer Matrix werden als 0 gewertet.
Diese Funktion ist immer dann nützlich, wenn die einzelnen Produkte nicht ange-
zeigt werden müssen oder sollen, sondern nur die Endsumme. Als Argumente
werden normalerweise (wie in den meisten Funktionen) Bereichsnamen oder Be-
reichsadressen angegeben, wie das folgende Beispiel demonstriert:
Abbildung 5.49 Die Funktion SUMMENPRODUKT() liefert das Gesamtgewicht
in einem Zug.
SUMMEWENN()
SUMIF()
Syntax:
SUMMEWENN( Bereich ; Suchkriterien ; Summe_Bereich)
Beispiel:
=SUMMEWENN(A6:A14;C5;B6:B14) siehe Abbildung 5.50
Search JabSto ::




Custom Search