Microsoft Office Tutorials and References
In Depth Information
Operator
Beispiel
Bedeutung
Priorität
<>
B5<>B7
ungleich
10
kleiner/gleich
10
<=
B5<=B7
größer/gleich
10
>=
B5>=B7
Die Priorität bestimmt die Reihenfolge, in der Excel die Operatoren auswertet.
Nehmen Sie das folgende Beispiel: Ein numerischer Ausdruck lautet: =5+6*3-7 .
Würde das Programm schlicht von links nach rechts vorgehen, ergäbe sich
5+6=11 , 11*3=33 und schließlich 33-7=26 . Tatsächlich aber führt Excel 2010 kor-
rekterweise zunächst die Multiplikation durch, die Priorität vor der Addition und
Subtraktion hat: 6*3=18 und 5+18-7=16.
Die Operation mit der höheren Priorität wird also zuerst ausgeführt. Bei Operato-
ren derselben Priorität wird von links nach rechts gearbeitet. Soll die Rangfolge
der Prioritäten unterlaufen werden, kann wie üblich mit Klammern gearbeitet
werden. Bei =(5*6)*(3-7) wird zunächst das Innere der beiden Klammern be-
rechnet. Das ergibt: =30*-4 , also =-120 .
1.6
Hinweise zu den Grundrechenarten
Im Folgenden werden zunächst noch einige Hinweise zu den Grundrechenarten
gegeben, die in der Praxis vermutlich am häufigsten in den Formeln verwendet
werden.
Addition und Subtraktion
Die folgende Liste zeigt einige Beispiele für korrekt eingegebene Formeln, um die
Schreibweise zu demonstrieren. Wie Sie sehen, können auch Datumswerte als
Operanden verwendet werden:
=12+27 =-15+33 =C17+F18-J21 =B14 =$B16-$C$16
=-(B13+B14+C17) =SUMME(B12:F12)+1000
=SUMME(B12:B17)+SUMME(C12:C19)
=DATUM(12;12;01)+90 =SUMME00+SUMME01
Search JabSto ::




Custom Search