Microsoft Office Tutorials and References
In Depth Information
Division durch Null abfangen
Bei der Division kann die Anzahl der Dezimalstellen, die der Quotient erhält, ganz
unterschiedlich sein. Hier kommt zu dem bei der Multiplikation angesprochenen
Rundungsproblem ein weiteres hinzu, das unbedingt beachtet werden muss: Die
Division durch Null ist nicht erlaubt.
Solange der Divisor direkt eingegeben wird, lässt sich dieser Fehler relativ leicht
vermeiden. Was aber, wenn der Divisor eine Zelladresse oder eine Funktion ist,
deren Ergebnis unvorhersehbar ist, wenn also der Divisor eine Variable, eine Un-
bekannte ist? Der Fall, dass ein Divisor mit dem Wert 0 verwendet wird, sollte un-
terbunden werden. Das ist möglich mit der im Kapitel 13, »Logische Funktionen«,
ausführlich beschriebenen WENN() -Funktion. Das kann etwa so aussehen:
=WENN(B3<>0;RUNDEN(A3/B3;2);"")
Wenn der Wert der Zelle B3 ungleich 0 ist, wird die Division A3/B3 durchgeführt;
ist B3 aber tatsächlich gleich 0, findet die Division erst gar nicht statt, die Zelle
bleibt leer. Stattdessen könnte auch ein entsprechender Hinweis ausgegeben wer-
den.
1.7
Texte verketten
Gelegentlich ist es sinnvoll, eine Zeichenfolge in einer Zelle durch eine Formel zu
erzeugen, die verschiedene Zeichen oder Zeichenfolgen verknüpft. Angenommen,
Sie wollen Artikelnummern um zwei Zeichen erweitern, die die Warengruppe be-
inhalten. Wenn Sie in die Zelle C9 =C5&C8 eintragen, wird der Inhalt von Zelle C5
mit dem Inhalt von Zelle C8 verkettet. Wenn C5 das Warengruppenkennzeichen
PX enthält und C8 die Artikelnummer 3370086 , ist das Ergebnis in Zelle C9
PX3370086 . Es macht übrigens nichts aus, wenn die Artikelnummer in C8 als Zahl
und nicht als Zeichenfolge eingetragen worden ist. Der Operator wandelt die Zahl
automatisch in eine Zeichenfolge um.
Anschließend können Sie diese Formel noch in ihr Ergebnis verwandeln. Kopieren
Sie die Zellen in die Zwischenablage und fügen Sie sie an derselben Stelle wieder
ein, indem Sie über das Kontextmenü Inhalte einfügen aufrufen und die Option
Werte verwenden. Um zwischen den Textelementen ein Leerzeichen einzufügen,
schreiben Sie: =C5&" "&C8 .
Search JabSto ::




Custom Search