Microsoft Office Tutorials and References
In Depth Information
verzweigt und diese ausgeführt. Die Funktion hat deshalb drei Argumente, die in
der vorgeschriebenen Reihenfolge eingetragen werden müssen, weil sonst uner-
wünschte Ergebnisse produziert werden.
Prüfung ist eine Bedingung in Form eines logischen Ausdrucks.
Eine Anweisung für den Fall, dass die Bedingung erfüllt ist, die als Dann_Wert
bezeichnet wird.
Eine Anweisung für den Fall, dass die Bedingung nicht erfüllt ist, der Sonst_
Wert .
Sowohl bei der Formulierung der Bedingungen als auch bei der Formulierung der
WAHR - und FALSCH -Anweisungen können natürlich alle sinnvollen Kombinationen
von Operatoren und Funktionen benutzt werden.
Die WENN() -Funktion kann generell für zwei ganz unterschiedliche Zwecke einge-
setzt werden:
1. Die Funktion erlaubt die Durchführung von Prüfungen. Zum Beispiel kann
mit dieser Funktion die Frage beantwortet werden, ob bestimmte Grenz-
werte überschritten sind, ob Abweichungen von einer Norm vorliegen
oder ob bestimmte Zielwerte erreicht worden sind.
2. Mit der WENN() -Funktion kann Excel veranlasst werden, unterschiedliche
Operationen durchzuführen, je nachdem, ob eine Bedingung erfüllt ist.
Das entspricht etwa einer Verzweigung, die in allen Computersprachen zu
den Grundoperationen gehört.
Allerdings gilt die Verzweigung immer nur in Bezug auf das Ergebnis in der Zelle
selbst. Es ist nicht möglich, mit der WENN() -Funktion direkt einen unterschiedli-
chen Wert in eine andere Zelle einzutragen. Es ist zwar möglich, etwa in der Zelle
B3 zu schreiben:
=WENN(B1>1000;B2=100;B2=200)
Ist B1 tatsächlich größer 1.000, bedeutet diese Formel aber lediglich, dass Excel
nun prüft, ob die Zelle B2 tatsächlich den Wert 100 enthält. Ist das der Fall, ist das
Ergebnis in Zelle B3 der Wert WAHR.
Eine direkte Wert-Zuweisung an eine Zelle, die dann eventuell auch Werte, die bis-
her in dieser Zelle eingetragen waren, überschreibt, kann nur über Makrobefehle
Search JabSto ::




Custom Search