Microsoft Office Tutorials and References
In Depth Information
Allerdings kann im Fall von Zeichenfolgenvergleichen eine unangenehme Überra-
schung auftreten. Die Bedingung, dass in der Zelle B10 der Name »Berlin« steht,
ist nur dann erfüllt, wenn dort tatsächlich auch nur Berlin steht. Ein Fehler, der bei
der Arbeit mit Excel gelegentlich plagt, weil er so schwer erkennbar ist, besteht da-
rin, überflüssige Leerzeichen zu benutzen. Wenn also hinter dem Wort Berlin ver-
sehentlich noch einmal die Leertaste gedrückt worden ist, wird Excel sich so ver-
halten, als sei der Inhalt der Zelle B10 nicht »Berlin«. Im strengen Sinne stimmt das
ja auch, aber zu sehen ist der Unterschied nur, wenn im Bearbeitungsfeld (Ende)
gedrückt wird. Der Fehler kann allerdings durch die Funktion = GLÄTTEN() abge-
fangen werden. Die Formel
=WENN(GLÄTTEN(B10)="Berlin" …
ist gegen die angesprochene Fehlermöglichkeit gefeit. Die Funktion GLÄTTEN() ist
eine Text-Funktion, die überflüssige Leerzeichen entfernt.
13.6
Prüfungen mit komplexen Bedingungen
Das Argument Prüfung kann auch aus mehreren Einzelbedingungen zusammen-
gesetzt sein. In vielen Fällen ist eine Operation gleich von mehreren Bedingungen
abhängig. Eine Komponente eines Produkts soll nur dann bei einem bestimmten
Lieferanten bestellt werden, wenn der Preis akzeptabel ist und gleichzeitig die Lie-
ferfrist maximal einen Monat beträgt. Die Formel könnte heißen:
=WENN(UND(C12<12500;D12<4);"bestellen";"nicht bestellen")
Die Zelle C12 enthält den Preis, die Zelle D12 die Lieferzeit in Wochen. Die Bedin-
gung ist nur dann erfüllt, wenn beide Teile der Bedingung gleichzeitig erfüllt sind.
In anderen Fällen hängt eine Entscheidung davon ab, ob eine bestimmte Bedingung
erfüllt ist oder eine andere. Im Beispiel wäre denkbar, dass auch ein höherer Preis
akzeptiert wird, wenn die Lieferfrist kurz ist. Eine kleine Änderung der Formel trägt
der Situation Rechnung. Statt der Funktion UND() wird ODER() eingesetzt:
=WENN(ODER(C12<12500;D12<4);"bestellen";"nicht bestellen")
Die neue Bedingung ist in drei Fällen wahr:
1. Der erste Teil der Bedingung ist erfüllt.
2. Der zweite Teil der Bedingung ist erfüllt.
3. Beide Bedingungen sind erfüllt.
Search JabSto ::




Custom Search