Microsoft Office Tutorials and References
In Depth Information
Beispiel für bedingte Berechnungen
Nehmen Sie folgendes einfache Beispiel: Sie haben in einer Tabelle in den Spalten
A und B ab Zeile 3 sowohl Zahlen als auch Texteinträge. Sie wollen in C das Pro-
dukt von A und B ausgeben, falls in der Zeile entsprechende Werte vorhanden
sind. Wenn Sie nun in C3 die Formel =A3*B3 eintragen und nach unten kopieren,
dann erhalten Sie immer dann, wenn in Spalte A und B keine Zahlen stehen, die
Fehlermeldung #WERT! , weil ja mit einem Text nicht multipliziert werden kann.
Um dies zu vermeiden, können Sie in C3 eintragen:
=WENN(UND(ISTZAHL(A3);ISTZAHL(B3);A3*B3;"")
Dann wird das Produkt nur gebildet, wenn beide Zellen eine Zahl enthalten, sonst
wird eine leere Zeichenfolge ausgegeben. Wenn Sie diese Formel nach unten ko-
pieren, dann bleiben Ihnen die unangenehmen Fehlermeldungen erspart. (Die
vorgegebenen Fehlermeldungen sind in Abschnitt 1.6, »Hinweise zu den Grund-
rechenarten, beschrieben«.)
14.2
Funktionen zur Prüfung des Datentyps
Elf der folgenden Funktionen beginnen mit dem Präfix IST und dienen dem
Zweck, zu prüfen, ob es sich bei dem angegebenen Argument um einen bestimm-
ten Datentyp handelt. Das erlaubt insbesondere in der Kombination mit der
WENN() -Funktion bedingte Verfahren einzurichten, also etwa je nach dem vorlie-
genden Datentyp unterschiedliche Berechnungsschritte vorzunehmen. Sehr nütz-
lich sind diese Funktionen aber auch im Zusammenhang mit der bedingten For-
matierung oder als Teil von Gültigkeitsregeln.
Während die Funktion TYP() ganz allgemein nach dem Datentyp des angegebe-
nen Arguments fragt, werden die IST -Funktionen eingesetzt, um gezielt zu prüfen,
ob ein bestimmter Datentyp vorliegt. Das Argument Wert kann dabei ein Bereichs-
name, ein Zellbezug, eine Zahl, ein Text, ein logischer Wert, ein Formelausdruck
ohne Gleichheitszeichen oder ein Fehlerwert sein. Das Ergebnis der Funktionen ist
jeweils ein logischer Wert, also WAHR oder FALSCH .
Search JabSto ::




Custom Search