Microsoft Office Tutorials and References
In Depth Information
Dies gilt nicht, wenn der Fehlerwert #NV direkt in die Zelle eingetragen wird, da
dies keine Funktion darstellt.
Für einen Bereich kann die Funktion auch als Matrixformel eingegeben werden.
Formeln, die sich auf eine Zelle beziehen, in der #NV eingetragen ist, liefern auch
#NV. Das gilt auch, wenn eine solche Zelle im Bereich einer SUMME() -Funktion
vorkommt. Die Funktion ANZAHL() dagegen behandelt eine Zelle mit =NV() wie
eine leere Zelle.
TYP()
TYPE()
Syntax:
TYP( Wert )
Beispiel:
=TYP(15)
ergibt 1
Die Funktion TYP() wird verwendet, um den Datentyp des angegebenen Argu-
ments Wert abzufragen. Als Ergebnis werden numerische Typkennzeichen gelie-
fert, die in der folgenden Tabelle zusammengestellt sind:
Argument
Rückgabewert
Zahl
1
Text
2
Wahrheitswert
4
Fehlerwert
16
Matrix
64
Die Funktion ist nützlich, um festzustellen, ob das Ergebnis einer anderen Funk-
tion oder einer Formel einem bestimmten Datentyp entspricht. Dies ist unter Um-
ständen notwendig, wenn ein Wert als Argument für eine Funktion oder inner-
halb einer Formel verwendet werden soll, die einen bestimmten Datentyp
erwartet. Die Formel
=WENN(TYP(A11)=1;A11*1,19;"Wert in A11 ist keine Zahl")
prüft zunächst, ob die Zelle A11 eine Zahl enthält, bevor die Multiplikation mit
dem angegebenen Faktor 1,19 ausgeführt wird.
Search JabSto ::




Custom Search