Microsoft Office Tutorials and References
In Depth Information
6.9 Matrixformeln
Matrixformeln bearbeiten
Erstellen Sie eine Formel, die aus der Absatzkalkulation
die Umsatzmengen der Produktkategorien berechnet.
Für diese Berechnung brauchen Sie eine Kombination
aus den Funktionen SUMME() und WENN() . Es gibt zwar
eine Funktion SUMMEWENN() , die diese Aufgabe lösen
könnte, die Matrixvariante fist aber wesentlich besser,
weil sie mehr Varianten integrieren kann. Schreiben Sie
diese Formel in die Zelle B10:
Sie können diese Matrix jetzt nur als Ganzes bearbeiten.
Der Versuch, eine einzelne Zelle daraus zu ändern oder
zu löschen, führt zur Fehlermeldung:
Teile eines Arrays können nicht geändert werden.
Markieren Sie für Änderungen immer den gesamten
Bereich, löschen Sie den Inhalt, und geben Sie die
Formel neu ein. Auch der Versuch, die Matrix zu erweitern,
bringt keine brauchbaren Resultate, die Kopie der
Matrix würde wieder eine neue Matrix produzieren.
=SUMME(WENN($B$4:$F$4=A10;$B$7:$F$7))
Die WENN() -Funktion stellt eine Bedingung auf
(WENN der Bereich mit den Sortimentsangaben mit
dem Text in Zelle A10 übereinstimmt) und die davor
geschaltete Summe summiert alle Zellen aus dem
Umsatzbereich B7:F7, die infrage kommen. Drücken
Sie zum Abschluss der Formel wieder (STRG) +
(UMSCHALT) + (EINGABE) . Mit der absoluten
Adressierung der beiden Matrizen haben Sie dafür gesorgt,
dass die Formel für weitere Auswertungszeilen
kopierbar fist. Ziehen Sie das Füllkästchen am
Zellzeiger von B10 nach unten, um auch die Auswertung
für die zweite Kategorie zu erhalten:
Jede Bearbeitung der Formel schließen Sie wieder mit
(STRG) + (UMSCHALT) + (EINGABE) ab, die Matrixklammern
rund um die Formel dürfen nie fehlen.
Matrixformeln mit Funktionen
Bis zu diesem Punkt fist die Matrixformel in unserem
Beispiel noch nicht besonders nützlich, denn das Ergebnis
ließe sich auch mit einer einfachen Multiplikation
erzielen. Interessant wird es erst, wenn komplexere
Auswertungen anstehen wie diese:
Abbildung 6.58
Die Matrixformel berechnet ganze
Bereiche.
Abbildung 6.59
Matrixfunktion mit SUMME() und WENN()
 
Search JabSto ::




Custom Search