Microsoft Office Tutorials and References
In Depth Information
6.11 Mit Funktionen zaubern
SVERWEIS mit direktem Bereichsverweis
wert ausgegeben werden. Das zweite Beispiel zeigt eine
Kostenaufstellung mit Kostenartennummern. Die
Bezeichnung der Kostenart sollte aus dem zweiten
Tabellenblatt abgerufen werden, im nächsten Schritt muss
auch die Kostengruppe ermittelt werden.
In der Praxis häufiger fist der direkte SVERWEIS, der eine
Schlüsselnummer in der ersten Spalte des Bereiches
sucht. Ist die Nummer nicht zu finden, muss ein
FehlerAbbildung 6.73
SVERWEIS-Aufgabe mit
direktem Bereichsverweis
1. Markieren Sie die Liste der Kostenarten mit (STRG) +
(UMSCHALT) + (*) , und weisen Sie dem Bereich über den
Namens-Manager den Bereichsnamen KLISTE zu.
Bereichsnamen für SVERWEIS-Matrizen
Arbeiten Sie bei Verweisen mit größeren Listen immer
mit Bereichsnamen oder Tabellen. Wenn sich der
Referenzbereich ändert, haben Sie schneller einen
Bereichsnamen angepasst als Dutzende von Formeln repariert.
Mit einem dynamischen Bereichsnamen passt sich der
Name automatisch an die Anzahl der Einträge in Zeile 1
und Spalte A an:
Schreiben Sie in Zelle D5 der Kostenträgerrechnung eine
Formel, die die Bezeichnung der Kostenart in Zelle B5 findet.
Die erste Spalte der Matrix muss dazu nicht sortiert sein:
D5: =SVERWEIS(B5;KLISTE;2;FALSCH)
Dieser Verweis sucht nach der Kostenart und gibt das
Ergebnis aus Spalte 2 wieder. Ist die Nummer nicht in
der ersten Spalte zu finden, fist das Ergebnis der
Funktion ein Fehlerwert (#NV!).
=BEREICH.VERSCHIEBEN(Kostenträger!$A$1;0;0;ANZAHL
2(Kostenträger!$A:$A);ANZAHL2(Kostenträger!$1:$1))
Fehler mit WENNFEHLER abfangen
Mit der Funktion WENNFEHLER stellen Sie sicher, dass
der SVERWEIS keine Fehlermeldung ausgibt, damit kön-
nen Sie die Formel auch entsprechend weit nach unten
kopieren. Geben Sie im zweiten Argument von
WENNFEHLER zwei Anführungszeichen ein, bleibt die Zelle
leer, Sie können aber auch einen Ersatztext angeben.
Kopieren Sie die Formel nach unten, und berechnen Sie
gleich die Gruppe. Dazu runden Sie die
Kostenartennummer auf den nächsten Hunderterwert ab:
E5: =SVERWEIS(ABRUNDEN(B5;-2);KLISTE;2;FALSCH)
Anstelle von FALSCH für das Argument Bereich_
Verweis können Sie auch eine 0 eintragen.
TIPP
=WENNFEHLER(SVERWEIS(B5;KLISTE;2;
FALSCH);““)
 
Search JabSto ::




Custom Search