Microsoft Office Tutorials and References
In Depth Information
6.11.2 Alternative zum SVERWEIS: INDEX und VERGLEICH
Abbildung 6.74 Lagerliste mit Artikelsuche
6.11.2 Alternative zum SVERWEIS:
INDEX und VERGLEICH
In der Praxis eignet sich nicht jede Liste für einen
Verweis mit SVERWEIS. Importierte Listen aus ERP-Syste-
men (SAP) können oft nicht sicherstellen, dass die erste
Spalte die Suchbegriffe enthält. Greifen Sie in diesem
Fall zur Kombination aus INDEX und VERGLEICH:
Diese Funktion vergleicht den in der Zelle B2
eingestellten Artikelnamen mit der ganzen Spalte. Das letzte
Argument sorgt wieder für eine genaue Übereinstim-
mung:
=VERGLEICH(B2;Bezeichnung;0)
Kombinieren Sie diese Funktion mit dem Index auf die
Spalte Bestand, erhalten Sie den passenden Wert für
die Zelle C2. Für die übrigen Verweise ändern Sie nur
noch die Matrix im ersten Argument von INDEX:
Praxisbeispiel: Artikelsuche im Lagerbestand
Das Tabellenblatt enthält eine Auflistung der
Lagerbestände mit Feldern von Artikelnummer bis Gesamtwert.
Die Artikelsuche soll eine schnelle Suche nach einem
bestimmten Artikel ermöglichen, mit gezielten
Verweisen werden Bestand, Lieferstatus und Preis ermittelt.
C2: =INDEX(Bestand;VERGLEICH(B2;
Bezeichnung;0);1)
D2: =INDEX(Preis__brutto;VERGLEICH(B2;
Bezeichnung;0);1)
1. Markieren Sie die gesamte Liste ab A4 mit (STRG) +
(UMSCHALT) + (*) .
E2: =INDEX(Status;VERGLEICH(B2;
Bezeichnung;0);1)
2. Wählen Sie Formeln/Definierte Namen/Aus Auswahl
erstellen .
3. Kreuzen Sie die Option Aus oberster Zeile an.
Damit sind die einzelnen Spalten der Liste mit
Bereichsnamen aus der Kopfzeile versehen, was das Arbeiten mit
Indizes sehr vereinfacht. Damit die Artikelsuche
erfolgreich fist, stellen Sie gleich die Artikelnamen über eine
Datenüberprüfungsliste bereit:
1. Markieren Sie Zelle B2, und wählen Sie Daten/Daten-
tools/Datenüberprüfung .
2. Schalten Sie unter Gültigkeitskriterien auf Liste um,
und geben Sie unter Quelle den Namen der
Artikelbezeichnungsspalte ein:
Abbildung 6.75 Gültigkeitsprüfungsliste für die Artikelnamen
Zulassen: Liste.
Quelle: =Bezeichnung
 
Search JabSto ::




Custom Search