Microsoft Office Tutorials and References
In Depth Information
6.11.5 Tabellenname in der Formel
6.11.6 Textkosmetik
Texte aus Dateien fremder Programme, über die
Zwischenablage einkopierte Daten oder HTML-Daten
landen oft nicht in der gewünschten Qualität in der Tabelle.
Überflüssige Leerzeichen und Sonderzeichen, falsche
Groß-/Kleinschreibung und andere Fehler sind bei
großen Datenmengen nur mit viel Zeitaufwand zu
eliminieren. Für diese Aufgabe sind diese Techniken der
Textkosmetik eine große Hilfe.
=ZEILE()*2
Eine.Reihe.mit.geraden.Nummern
=SPALTE()*2
=ZEILE()*2-1
Eine.Reihe.mit.ungeraden.
Nummern
=SPALTE()*2-1
Intervalle.mit.1.bis.n.Nummern.
(hier.0.und.1)..Das.zweite.Argument.
von. REST() .bestimmt.die.Anzahl.der.
sich.wiederholenden.Zahlen
=REST(ZEILE();2)
=REST(SPALTE();2)
=WENN(REST(ZEILE();2);Z
EILE();"")
Damit.werden.nur.die.ungeraden.
Zeilen/Spalten.nummeriert
Das Beispiel finden Sie auf der Buch-CD
unter Textkosmetik.xlsx .
CD-ROM
=WENN(REST(SPALTE();2);
ZEILE();"")
Überflüssige Leerzeichen entfernen
Die Funktion GLÄTTEN() löscht alle überflüssigen
Leerzeichen aus dem Text. Befinden sich diese am Beginn
oder Ende eines Texteintrages, werden sie vollständig
entfernt. Geben Sie diesen Text in die Zelle A1 ein (ohne
Anführungszeichen):
Tabelle 6.9 Beispiele für Füllreihen-Funktionen
6.11.5 Tabellenname in der Formel
Dateiname und Tabellenbezeichnung lassen sich in die
Kopf- oder Fußzeile integrieren. Wie sieht es aber mit der
Information in der Tabelle aus? Gibt es eine Möglichkeit,
den Namen des aktuellen Blattes auch auf der Tabelle
abzubilden? Die Funktion, die Sie dafür verwenden können,
heißt ZELLE() . Diese Formel gibt den Namen der Tabelle
aus dem Register wieder:
=ZELLE("Dateiname")
Abbildung 6.78 Überflüssige Leerzeichen werden gelöscht.
Der Tabellenname wird immer mit dem kompletten Pfad
der Mappe abgebildet. Wenn Sie diesen entfernen wollen,
greifen Sie zu den Textfunktionen RECHTS() und LÄNGE() .
Außerdem brauchen Sie die Funktion FINDEN() , mit der
Sie die rechte eckige Klammer der Mappenbezeichnung
ausfindig machen können.
Schreiben Sie in die Zelle A2 diese Formel:
=GLÄTTEN(A1)
Das Ergebnis: Der Text enthält nur noch Leerzeichen
zwischen den Wörtern.
Der Tabellenname ohne Pfad:
Groß-/Kleinschreibung
=RECHTS(ZELLE("Dateiname“);LÄNGE(ZELLE("Dateina
me“))-FINDEN("]“;ZELLE("Dateiname“)))
Diese Funktionen wandeln Texte in Groß- und
Kleinschrift um:
Der Pfad ohne Tabellenname:
=LINKS(ZELLE("Dateiname“);FINDEN("[";ZELLE("Datei-
name“))-2)
=GROSS()
Wandelt.einen.Text.in.Großbuchstaben.um
=GROSS2()
Wandelt.die.ersten.Buchstaben.aller.Wörter.
eines.Textes.in.Großbuchstaben.um
Das zweite Argument von ZELLE("Dateiname“) brauchen
Sie, wenn sich die Informationen auf mehreren
Tabellenblättern befinden. Ohne das Argument A1 wird sie nicht
berechnet, solange keine Neuberechnung stattfindet.
=KLEIN()
Wandelt.einen.Text.in.Kleinbuchstaben.um
Tabelle 6.10 Funktionen Groß-/Kleinschreibung
 
 
Search JabSto ::




Custom Search