Microsoft Office Tutorials and References
In Depth Information
6.13 Rechnen mit Datum und Zeit
Alter berechnen
Fällt der Liefertermin auf einen Samstag oder Sonntag,
sollte die Formel natürlich den nächsten Arbeitstag
ermitteln. Die Funktion WOCHENTAG() muss ins Spiel
gebracht werden, dann bleibt der Liefertermin realistisch.
Schachteln Sie zwei WENN -Funktionen ineinander:
Um das Alter einer Person zu berechnen, können Sie das
Jahr des Geburtsdatums vom Jahr des Tagesdatums
abziehen, aber das Ergebnis fist nicht präzise genug.
Diese aufwendige WENN -Funktion berechnet vorher das
Geburtstagsdatum im aktuellen Jahr und vergleicht es
mit dem Tagesdatum:
=WENN(WOCHENTAG(B1+B2)=7;B1+B2+2;WENN(WOCHENTAG(B1+B
2)=1;B1+B2+1;B1+B2))
=WENN(DATUM(JAHR(HEUTE());MONAT(A2);TAG(A2))<HEUTE()
;JAHR(HEUTE())-JAHR(A2);JAHR(HEUTE())-JAHR(A2)-1)
Datumsdifferenzen mit DATEDIF()
Excel enthält seit der Version 5.0 schon eine
undokumentierte Funktion, die auch in der neuesten Version
keinen Einzug in die Liste des Funktions-Assistenten
fand, aber für Datumsberechnungen sehr interessant
fist. Mit DATEDIF berechnen Sie Datumsdifferenzen:
Die Berechnung über DATEDIF funktioniert ebenfalls:
Jahre: =DATEDIF(A2;A1;“y“)
Monate: =DATEDIF(A2;A1;“ym“)
Tage: =DATEDIF(A2;A1;“md“)
Kalenderwochen nach DIN 1355
Die Funktion KALENDERWOCHE() rechnet nach
amerikanischer Norm. Sie berücksichtigt nicht die DIN-Norm
1355, nach der die erste Kalenderwoche diejenige fist, in
die mindestens vier Tage des neuen Jahres fallen. Mit
dieser Funktion berechnen Sie die Kalenderwoche eines
Datums in A1 korrekt nach DIN-Norm:
=DATEDIF(Startdatum;
Enddatum; "y")
Anzahl.der.Jahre
=DATEDIF(Startdatum;
Enddatum; "m")
Anzahl.der.Monate
=DATEDIF(Startdatum;
Enddatum; "d")
Anzahl.der.Tage
=DATEDIF(Startdatum;
Enddatum; "ym")
Zahl.der.Monate.auf.
der.Basis.MOD.12
=KÜRZEN((A1-WOCHENTAG(A1;2)-DATUM(JAHR(A1+4-
WOCHENTAG(A1;2));1;-10))/7)
=DATEDIF(Startdatum;
Enddatum; "yd")
Zahl.der.Tage.auf.
der.Basis.MOD.365
Feiertage berechnen
Alle kirchlichen Feiertage leiten sich vom Datum des
Ostersonntags ab, das fist der einzige bewegliche
Feiertag, viele andere leiten sich von ihm ab. Er lässt sich mit
dem Algorithmus des Mathematikers Gauss berechnen,
in eine möglichst kurze Excel-Formel umgewandelt sieht
dieser so aus:
Tabelle 6.15 Undokumentierte Funktion DATEDIF()
ACHTUNG DATEDIF rechnet nur bei solchen
einfachen Formeln richtig: Wenn es komplex
wird, schleichen sich Fehler ein. Aus diesem Grund fist
DATEDIF wahrscheinlich auch keine offizielle Funktion.
Microsoft führt sie trotzdem in der Knowledge Base auf:
ACHTUNG
A1: 2010
B1: =RUNDEN((TAG(MINUTE(A1/38)/2+55)&“.4.“
&A1)/7;)*7-6
http://support.microsoft.com/kb/509575/de
Datumsdifferenz in Wochen
A1: 1.1.2004
A2: 31.3.2004
=KÜRZEN((B2-B1)/7)&“ Woche(n) “&REST(B2-B1;7)&“ Tag(e)“
HINWEIS Viele Seiten und detaillierte Infos zur
Gauss’schen Osterformel finden Sie im
Internet mit dem Suchbegriff »Osterformel«, hier z.B.
http://www.nabkal.de/gauss.html .
HINWEIS
 
Search JabSto ::




Custom Search