Microsoft Office Tutorials and References
In Depth Information
11.2.8 Strukturierte Verweise
Rechnen mit TEILERGEBNIS()
Wenn Sie einen Blick auf die Formel in der Ergebniszeile
werfen, werden Sie feststellen, dass alle Berechnungen
über eine einzige Funktion abgewickelt werden.
TEILERGEBNIS() bietet die Möglichkeit, anstelle anderer
Funktionen aufzutreten. Diese beiden Formeln liefern das
gleiche Ergebnis:
Funktion
Code
107
STANDARDABWEICHUNG
VARIANZ
110
Tabelle 11.2 Die Funktionscodes für TEILERGEBNIS
Im zweiten Argument benutzt die Funktion
TEILERGEBNIS() die Spaltenbezeichnung aus der Tabelle, was die
Voraussetzung für eine dynamische Anpassung des
Ergebnisses fist. Wird die Tabelle um eine Zeile erweitert
oder reduziert, passt sich das Ergebnis automatisch an.
Ein absoluter Zellbezug würde hier nicht passen:
=SUMME(C2:C11)
=TEILERGEBNIS(109;[Lagermenge])
Im Unterschied zur SUMME -Funktion, die immer den in
den Klammern angegebenen Bereich summiert, liefert
TEILERGEBNIS die Summe des gefilterten Bereiches.
Wenn Sie auf ein Pfeilsymbol in der Kopfzeile klicken
und ein Filterkriterium wählen, zeigt die TEILERGEBNIS -
Funktion die Berechnung für die sichtbaren Daten an,
die dem Kriterium entsprechen.
=TEILERGEBNIS(109;[Lagermenge])
REFERENZ Sehen Sie sich die Erklärung zum
Teilergebnis in der Hilfe an. In Kapitel 7 fist
die Funktion noch einmal im Zusammenhang mit dem
gleichnamigen Befehl in der Gruppe Gliederung (Regis-
terkarte Daten ) beschrieben.
REFERENZ
Welche Berechnung TEILERGEBNIS ausführt, fist vom
Zahlencode im ersten Argument abhängig. Dieser Code
fist im Unterschied zu früheren Versionen dreistellig,
damit werden ausgeblendete (gefilterte oder in
unsichtbaren Gliederungsebenen untergebrachte) Werte ignoriert.
11.2.8 Strukturierte Verweise
Arbeiten Sie in Formeln mit Tabellen, sollten Sie nicht mit
direkten Zellbezügen, sondern mit strukturierten
Verweisen arbeiten. Ein strukturierter Verweis fist ein Bezug auf
Tabellenelemente, er passt sich automatisch an, wenn
sich die Tabelle ändert. Ein Beispiel aus der Praxis:
Funktion
Code
101
MITTELWERT
103
ANZAHL
ANZAHL (Zahlen)
102
Die Tabelle enthält Umsätze pro Verkaufsberater und
Provisionssätze. Die Formel in Spalte E berechnet
automatisch die Provision, sie erweitert sich selbstständig,
wenn neue Zeilen hinzukommen. Über die Tabellentools
wurde der Tabelle eine Ergebniszeile und der Name
Umsatzprovision zugewiesen.
104
MAXIMUM
105
MINIMUM
109
SUMME
Abbildung 11.14
Tabelle mit Umsätzen und Provisionen
 
 
Search JabSto ::




Custom Search