Microsoft Office Tutorials and References
In Depth Information
16.1.6 Dynamische Datenüberprüfungslisten
TIPP Gültigkeitslisten akzeptieren keine Bezü-
ge auf andere Arbeitsmappen als Quelle.
Sie können aber Verknüpfungen zu diesen Mappen in
die aktuelle Tabelle einfügen und diese als Quellbezüge
für die Listen angeben.
Die Datenüberprüfung für Zelle B2:
TIPP
Zulassen: Liste
Quelle: =WAHL($H$1;$D$2:$D$4;$E$2:$E$4;$F$2:$F$4)
Jetzt bietet die Zelle B2 immer die Städte des Landes
an, das in A2 gewählt wurde. Ein Schönheitsfehler bleibt
– die Zelle löscht sich nicht automatisch, wenn in A2 das
Land gewechselt wird. Eine Lösung für diese Aufgabe
finden Sie im anschließenden Praxisbeispiel
Kostenvoranschlag , in dem auch die Verwaltung der einzelnen
Listen dynamisch gemacht wird.
16.1.6 Dynamische Datenüberprüfungslisten
Mit der Listenautomatik alleine fist es nicht getan, sie fist
zwar für die Datenerfassung und für automatische
Spaltenergebnisse nützlich, bietet aber keine Flexibilität im
täglichen Umgang mit Listen. Datenüberprüfungslisten
können hier sehr viel Komfort bieten und Excel-Tabellen
in Formulare verwandeln, die (fast) selbstständig rechnen.
Praxis: Kostenvoranschlag
Angebote und Kostenvoranschläge zu schreiben, gehört
nicht zu den Lieblingsbeschäftigungen des
Handwerksmeisters, aber der Kunde fist König, und ohne Angebot
gibt es meist auch keinen Auftrag. Wenn nur das mühse-
lige Zusammensuchen der Positionen für die Stückliste
nicht wäre, das kostet Zeit und fist fehlerträchtig, weil
schnell mal eine Position verrutscht oder der falsche
Preis in die Spalte gerät.
Ein erstes Beispiel zeigt die Technik, wie Datenüberprü-
fungslisten konstruiert werden, die sich am Inhalt
anderer Zellen orientieren:
Sie finden das Beispiel auf der Buch-CD
unter Variable_DListen.xlsx .
CD-ROM
Die Tabelle Länderinfo enthält drei Länderspalten mit
Städtenamen. Präparieren Sie die Zelle A2 so, dass alle
Länder angezeigt werden, und erstellen Sie in B2 eine
Datenüberprüfungsliste, die alle Städte des in A2
gewählten Landes enthält.
Das Praxisbeispiel zeigt, wie ein Formular für
Kostenvoranschläge oder allgemeine Angebote präpariert wird,
sodass es automatisch nach Auswahl einer Kategorie
die richtigen Stücklisten liefert. Zum Einsatz kommt eine
dynamische Stückliste, d.h. eine Liste, die ihren Inhalt
automatisch den Einträgen der Spalte Kategorie anpasst.
Die Datenüberprüfung für Zelle A2:
Zulassen: Liste
CD-ROM Auf der Buch-CD unter Kostenvoranschlag.
xlsx finden Sie die Übungsdaten, die Lö-
sung unter Kostenvoranschlag_Loesung.xlsm enthält die
fertigen Gültigkeitsbereiche, Formeln und Makros.
Stellen Sie sicher, dass Ihr Vertrauensstellungscenter Makros
in Arbeitsmappen zulässt ( Datei -Menü/ Optionen ).
CD-ROM
Quelle: =$D$1:$F$1
Für die Suche nach dem gewählten Land schreiben Sie
in eine freie Zelle (H1) diese Formel:
=VERGLEICH($A$2;$D$1:$F$1;0)
Abbildung 16.12 Die Tabelle Länderinfo
 
Search JabSto ::




Custom Search