Microsoft Office Tutorials and References
In Depth Information
steht =SUMME(B5:B9) . Sie fügen bei Zeile 7 zwei Zeilen ein. Die Formel wird automatisch
auf =SUMME(B5:B11) erweitert. Wird dagegen bei Zeile 5 – also vor dem Bereich – eine Zeile
eingefügt, gehört sie nicht zum summierten Bereich, die Formel lautet =SUMME(B6:B12) .
Wird die letzte Zelle des Bereichs markiert und eine Zeile eingefügt, verschiebt Excel die
bisher letzte Zeile um eine Zeile nach unten. Aus =SUMME(B5:B12) wird =SUMME(B5:B13) .
Der Haken an der Sache ist, dass dadurch die Reihenfolge in dem Bereich möglicher-
weise nicht mehr der entspricht, die Sie haben wollen. Lässt sich das nicht durch eine
Sortierung regeln, ist es besser, die neue Zeile vor der Zeile einzufügen, die die Sum-
menformel enthält, und die Bereichsdefinition in der Formel zu korrigieren. Das oben
Gesagte gilt auch für benannte Bereiche.
Spezialfall Matrix
Bei Matrixformeln gilt die Einschränkung, dass in die Ergebnismatrix keine Zellen einge-
fügt werden können. Wenn Sie es versuchen, erhalten Sie eine Fehlermeldung. Ist es not-
wendig, muss die Matrixformel für den neuen Bereich neu eingegeben werden. Handelt es
sich um eine komplizierte Formel, können Sie einen kleinen Trick anwenden. Klicken Sie
doppelt auf die erste Formel. Markieren Sie den ganzen Eintrag und kopieren Sie ihn in
die Zwischenablage. Brechen Sie die Bearbeitung mit [Esc] ab. Markieren Sie mit
[Strg] + [/] die Ergebnismatrix und löschen Sie diese. Markieren Sie die neue Ergebnis-
matrix. Klicken Sie doppelt auf die aktive Zelle und verwenden Sie Bearbeiten Einfügen ,
um die alte Formel einzutragen. Nun müssen in der Regel die Bereiche für die Argumente
bzw. Operanden korrigiert werden. Markieren Sie diese per Doppelklick, und markieren
Sie die neuen Bereiche. Schließen Sie mit [Strg] + [ª] + [¢] ab.
Löschen
Wird der Inhalt einer Zelle gelöscht, auf die sich eine Formel bezieht, wird die leere
Zelle in der Formel so gewertet, als ob Sie den Wert 0 eingetragen hätten. Zu einem Pro-
blem wird das nur dann, wenn die Zelle den Wert für einen Operanden oder für ein Ar-
gument liefert, bei dem der Wert Null nicht zugelassen ist. Ein Beispiel ist die Division
durch Null oder das Argument Tag oder Monat bei der Funktion DATUM() . In diesen Fäl-
len liefert die Formel einen Fehlerwert.
Entfernen von Zellen
Wird nicht der Inhalt einer Zelle, sondern die Zelle selbst entfernt, verliert eine Formel,
die sich auf diese einzelne Zelle bezieht, eben diesen Bezug und reagiert mit der Fehler-
Search JabSto ::




Custom Search