Microsoft Office Tutorials and References
In Depth Information
Logische Funktionen werden benutzt, wenn es darum geht, zu prüfen, ob bestimmte
Tatsachen oder Bedingungen gegeben sind oder nicht. Eine logische Formel kann nicht
nur eine Bedingung enthalten, sondern auch mehrere gleichzeitig. Diese Bedingungen
können entweder alternativ oder additiv formuliert werden. Alternative Bedingungen
werden mit der Funktion ODER() verknüpft, additive Bedingungen mit der Funktion
UND() . Hier einige Beispiele:
=UND(B6>B7; B9>B1O)
=UND(A10>50; A10<100)
In diesen Fällen ist die Bedingung jeweils nur erfüllt, also WAHR , wenn beide Teilbedin-
gungen erfüllt sind.
=ODER(C9=12; C9=24)
=ODER(MONAT="Mai"; MONAT="Juni"; MONAT="Okt")
Bei diesen Formeln ist das Ergebnis WAHR , wenn die Zelle mit dem Namen Monat einen
der drei Monatsnamen enthält. Die Funktion NICHT() verneint einen Vergleich. Ein Bei-
spiel:
=NICHT(A1=100)
Diese Bedingung ist in allen Fällen erfüllt, bei denen Al <>100. Die Formeln
=A1<>100
=NICHT(Al=l00)
sind also austauschbar. Logische Vergleiche werden insbesondere auch mithilfe der
Funktion WENN() durchgeführt. Manchmal ist es aber praktischer, eine komplexe Bedin-
gung zunächst in einer Zelle zu prüfen und dann in einer Funktion WENN() nur den Wert
dieser Zelle abzufragen, als die komplexe Bedingung in die Funktion WENN() selbst mit
aufzunehmen. Das gilt insbesondere, wenn diese Bedingung an mehreren Stellen abge-
fragt werden muss.
16
WAHR oder FALSCH als Argumente
Um anzuzeigen, ob die Bedingung einer Funktion WENN() erfüllt ist, können auch die
Funktionen WAHR() und FALSCH() als Argumente benutzt werden. Das kann sinnvoll sein,
wenn bei einer Bedingung nicht gleich ersichtlich ist, ob die Bedingung erfüllt ist oder
nicht. Hier ein Beispiel:
=WENN(Gewinne01>500000; WAHR(); FALSCH())
Ergebnis: FALSCH , wenn Gewinne01 = 300000
Search JabSto ::




Custom Search