Microsoft Office Tutorials and References
In Depth Information
Abbildung 16.77 Beispiel für logische Formeln
Die Funktion WENN() prüft zunächst, ob eine bestimmte Bedingung erfüllt, also WAHR ist.
Trifft dieses zu, wird die Anweisung WAHR ausgeführt und bestimmt das Ergebnis der For-
mel. Trifft dies nicht zu, wird zur Anweisung FALSCH verzweigt und diese ausgeführt. Die
Funktion hat deshalb drei Argumente, die in der vorgeschriebenen Reihenfolge einge-
tragen werden müssen, weil andernfalls unerwünschte Ergebnisse produziert würden:
1. Prüfung : eine Bedingung in Form eines logischen Ausdrucks
2. Dann_Wert : eine Anweisung für den Fall, dass die Bedingung erfüllt ist
3. Sonst_Wert : eine Anweisung für den Fall, dass die Bedingung nicht erfüllt ist
Die Funktion WENN() kann generell für zwei ganz unterschiedliche Zwecke eingesetzt
werden:
1.
Die Funktion erlaubt die Durchführung von Prüfungen. Zum Beispiel kann mit dieser
Funktion die Frage beantwortet werden, ob bestimmte Grenzwerte überschritten
wurden, Abweichungen von einer Norm vorliegen oder ob bestimmte Zielwerte
erreicht worden sind.
2.
Mit der Funktion WENN() kann Excel veranlasst werden, unterschiedliche Opera-
tionen durchzuführen, je nachdem, ob eine Bedingung erfüllt ist oder nicht. Das
entspricht etwa einer Verzweigung, die in allen Computersprachen zu den Grund-
operationen gehört.
Allerdings gilt die Verzweigung immer nur in Bezug auf das Ergebnis in der Zelle
selbst. Es ist nicht möglich, mit der Funktion WENN() direkt einen neuen Wert in eine
andere Zelle einzutragen. Es ist zwar möglich, etwa in der Zelle B3 zu schreiben:
=WENN(B1>1000; B2=100; B2=200)
Ist B1 tatsächlich größer 1.000, bedeutet diese Formel aber lediglich, dass Excel nun
prüft, ob die Zelle B2 tatsächlich den Wert 100 enthält. Ist dies der Fall, ist das Ergeb-
nis in Zelle B3 der Wert WAHR .
Search JabSto ::




Custom Search