Microsoft Office Tutorials and References
In Depth Information
Während es im letzten Fall in erster Linie um die Prüfung der Entwicklung der Kunden-
umsätze ging, soll die nächste Formel zeigen, wie die Funktion WENN() benutzt werden
kann, um auf verschiedene Zustände unterschiedlich zu reagieren. Die Firma könnte
auf die Idee kommen, die Höhe eines Bonus zum Jahresende von der Umsatzentwick-
lung abhängig zu machen. Die Kunden, deren Umsatz über 250.000 € liegt, sollen einen
Bonus von 0,5 % erhalten, die anderen gehen leer aus. Die Formel für diesen Fall:
=WENN(C5>250000; C5*0,05; 0)
Sowohl bei der Formulierung der Bedingungen als auch bei der Formulierung der
Anweisungen WAHR und FALSCH können natürlich alle sinnvollen Kombinationen von
Operatoren und Funktionen benutzt werden.
Bedingte Textanzeige
Besteht die Möglichkeit, in einem Arbeitsblatt Texte nur unter bestimmten Vorausset-
zungen zu drucken? Die Funktion WENN() bietet sich auch in diesem Fall an. Angenom-
men, das Arbeitsblatt wird zur Aufbereitung und zum Druck von Rechnungen benutzt.
Auf den Dezember-Rechnungen soll im Rechnungsfuß ein Hinweis auf ein spezielles
Weihnachtsangebot erscheinen. Die Lösung könnte folgende Formel sein:
=WENN(MONAT(JETZT())=12; "Sonderrabatt von 20% für alle Orientteppiche"; "")
Prüfung von Texten
Die Funktion WENN() kann selbstverständlich nicht nur zur Prüfung numerischer Zellen
benutzt werden. Zellen, die Texte oder Zeichenfolgen enthalten, können ebenfalls be-
fragt werden. Der Text kann direkt eingetragen sein oder indirekt über einen Zellbezug
oder als Ergebnis einer Formel, die als Ergebnis eine Zeichenfolge bereitstellt. Hier ein
einfaches Beispiel:
=WENN(Bl0="Berlin"; "Hauptstadt"; "")
Allerdings kann im Fall von Zeichenfolgenvergleichen eine unangenehme Überra-
schung auftreten. Die Bedingung, dass in der Zelle B10 der Name Berlin steht, ist nur
dann erfüllt, wenn dort tatsächlich auch nur Berlin steht. Ein Fehler, der bei der Arbeit
mit Excel gelegentlich plagt, weil er so schwer erkennbar ist, besteht darin, dass über-
flüssige Leerzeichen benutzt werden. Wenn also hinter dem Wort Berlin versehentlich
noch einmal die Leertaste gedrückt worden ist, wird Excel sich so verhalten, als sei der
Inhalt der Zelle B10 nicht Berlin . Im strengen Sinne stimmt das ja auch, aber zu sehen ist
Search JabSto ::




Custom Search