Microsoft Office Tutorials and References
In Depth Information
der Unterschied nur, wenn im Bearbeitungsfeld [Ende] gedrückt wird. Der Fehler kann
allerdings durch die Funktion =GLÄTTEN(B10) abgefangen werden. Die Formel
=WENN(GLÄTTEN(B10)="Berlin"...
ist gegen die angesprochene Fehlermöglichkeit gefeit. Die Funktion GLÄTTEN() ist eine
Text-Funktion, die überflüssige Leerzeichen entfernt.
Prüfungen mit komplexen Bedingungen
Das Argument Prüfung kann aus mehreren Einzelbedingungen zusammengesetzt sein.
In vielen Fällen ist eine Operation gleich von mehreren Bedingungen abhängig. Eine
Komponente eines Produkts soll nur dann bei einem bestimmten Lieferanten bestellt
werden, wenn der Preis akzeptabel ist und gleichzeitig die Lieferfrist maximal einen
Monat beträgt. Die Formel könnte heißen:
=WENN(UND(C12<12500; D12<4); "bestellen"; "nicht bestellen")
Die Zelle C12 enthält den Preis, die Zelle D12 die Lieferzeit in Wochen. Die Bedingung
ist nur dann erfüllt, wenn beide Teile der Bedingung gleichzeitig erfüllt sind. In anderen
Fällen hängt eine Entscheidung davon ab, ob eine bestimmte Bedingung erfüllt ist oder
eine andere. Im Beispiel wäre denkbar, dass auch ein höherer Preis akzeptiert wird,
wenn die Lieferfrist kurz ist. Eine kleine Änderung der Formel trägt der Situation Rech-
nung. Statt der Funktion UND() wird ODER() eingesetzt:
=WENN(ODER(C12<l2500; Dl2<4); "bestellen"; "nicht bestellen")
Die neue Bedingung ist in drei Fällen WAHR :
16
1.
Der erste Teil der Bedingung ist erfüllt.
2.
Der zweite Teil der Bedingung ist erfüllt.
3.
Beide Bedingungen sind erfüllt.
Die Funktion ODER() ist also kein ausschließendes Oder. Das ausschließende Oder
würde den dritten Fall nicht zulassen. Ein solches Entweder-Oder, aber nicht beides
gleichzeitig könnte erreicht werden durch eine Kombination von UND() und ODER() .
=WENN(UND(ODER(B10=5; C10=7); NICHT(UND(B10=5; C10=7))); "ok"; "prüfen")
Wenn die Zelle B10 den Wert 5 hat und gleichzeitig die Zelle C10 den Wert 7, ist das Er-
gebnis prüfen , die Bedingung ist also nicht erfüllt.
Search JabSto ::




Custom Search