Microsoft Office Tutorials and References
In Depth Information
WENN()
Syntax:
WENN( Prüfung ; Dann_Wert ; Sonst_Wert)
Beispiel:
=WENN(A2>B2; A2-B2; B2-A2)
Ergebnis:
Die Inhalte der beiden Zellen werden stets so voneinander subtrahiert,
dass der kleinere Wert vom größeren abgezogen wird.
Die Funktion liefert in Abhängigkeit von der in Prüfung angegebenen Bedingung je nach
dem Ergebnis der Wahrheitsprüfung unterschiedliche Resultate. Trifft die Bedingung zu,
gibt die Funktion den Dann_Wert aus, trifft sie nicht zu, wird der Sonst_Wert ausgegeben.
Ist dieser nicht angegeben, wird der logische Wert ausgegeben, den die Prüfung liefert.
Die Funktion erlaubt die Durchführung von Prüfungen, z. B. kann mit dieser Funktion
die Frage beantwortet werden, ob bestimmte Grenzwerte überschritten oder bestimmte
Zielwerte erreicht worden sind. Es kann auch veranlasst werden, unterschiedliche
Werte in eine Zelle einzutragen oder unterschiedliche Berechnungen durchzuführen, je
nachdem, ob eine Bedingung erfüllt ist oder nicht.
Als Ergebnis der Wahrheitsprüfung kann eine Verschachtelung durch weitere Verwen-
dung der Funktion WENN() erfolgen. Seit Excel 2007 sind bis zu 64 Schachtelungen erlaubt,
in den älteren Versionen nur 7.
WENNFEHLER()
Syntax:
WENNFEHLER( Wert ; Wert_falls_Fehler )
Beispiel:
=WENNFEHLER(Betrag/Tage; "Unerlaubte Division")
Ergebnis:
Unerlaubte Division , wenn Tage = 0
Die Funktion prüft das Argument Wert . Liefert diese Prüfung einen Fehler, wird das an-
gezeigt, was mit dem Argument Wert_falls_Fehler angegeben ist. Das kann beispiels-
weise eine Beschreibung des Fehlers sein oder ein Vorgabewert. Ansonsten liefert die
Funktion das Ergebnis von Wert . Für Wert kann auch eine Array-Formel verwendet wer-
den. Die Funktion liefert dann für jede Zelle des Arrays ein entsprechendes Ergebnis.
Search JabSto ::




Custom Search