Microsoft Office Tutorials and References
In Depth Information
In der Nachbarzelle C4 (unterhalb von Di) prüfen wir zuerst gleichzeitig mit der
UND -Funktion, ob Zelle B4 noch leer ist und ob der Wochentag von A1 dem Wert
aus C3 entspricht.
Ist diese Prüfung WAHR , soll in Zelle C4 das Datum aus A1 übernommen werden.
Ist diese Prüfung FALSCH , wird überprüft, ob B4 leer ist. Ist diese Prüfung WAHR ,
soll auch C4 leer bleiben.
Ist diese Prüfung FALSCH , wird zum Wert aus B4 eine 1 addiert, d. h., in Zelle C4
würde dann der zweite Tag des aktuellen Monats ebenfalls im Datumsformat TT ,
also 02, stehen. Die Formel in Zelle C4 lautet:
=WENN(UND(B4="";WOCHENTAG($A$1)=C3);$A$1;WENN(B4="";"";B4+1)).
Diese Formel können Sie nun bis zur Zelle H4 kopieren.
In der zweiten bis vierten Zeile des Kalenders können Sie jeweils zum Vortag den
Wert 1 hinzuaddieren. In Zelle B5 steht somit die Formel =H4+1 und in der Zelle B6
=B5+1 . Kopieren Sie zunächst die Formel aus B5 bis zur Zelle H5 . Da alle Monate
mindestens 28 Tage haben, markieren Sie den Bereich von B5:H5 und kopieren die
Formeln bis in die Zeile 7 nach unten.
In der letzten Woche eines Monats prüfen Sie für jeden Tag mit der TAG -Funk-
tion, die den Wert des Tages (1–31) aus einem Datum ausgibt, ob der Vortag +1
dem Wert 1 entspricht, d. h. der erste Tag des nächsten Monats ist. Wenn diese
Prüfung WAHR ist, soll die Zelle leer bleiben, sonst soll zum Vortag der Wert 1
hinzuaddiert werden. In Zelle B8 steht somit die Formel:
=WENN(TAG(H7+1)=1;"";H7+1).
Ab dem zweiten Tag der Woche stellen Sie der eben beschriebenen Prüfung noch
die Prüfung voran, ob die Zelle links der aktuellen Zelle bereits leer ist. Die Formel
in C8 lautet entsprechend:
=WENN(B8="";"";WENN(TAG(B8+1)=1;"";B8+1))
In der ersten Spalte ermitteln Sie mit der Funktion KALENDERWOCHE jeweils in der
ersten Zeile die aktuelle Kalenderwoche aus dem Datum des ersten Tages des
Monats. Die Formel in A4 ist =KALENDERWOCHE(A1;2) . Der zweite Parameter gibt
an, dass die Woche mit einem Montag beginnen soll.
Search JabSto ::




Custom Search